SchemaJsonFileLocater Class
A SchemaLocator implementation for locating JSON Schema files from the file system using configurable search paths.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(): SchemaJsonFileLocater | ||
getSchema(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | Schema> | Attempts to retrieve a Schema with the given SchemaKey by using the configured | |
getSchemaInfo(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | SchemaInfo> | Gets the schema info which matches the provided SchemaKey. | |
getSchemaSync(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): undefined | Schema | Attempts to retrieve a Schema with the given SchemaKey by using the configured |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addSchemaSearchPath(schemaPath: string): void Inherited | SchemaFileLocater | Add one search path used by this locator to find the |
addSchemaSearchPaths(schemaPaths: string[]): void Inherited | SchemaFileLocater | Adds more search paths used by this locator to find the |
Defined in
Last Updated: 23 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.