SchemaFileLocater Class
Abstract class to hold common/overlapping functionality between SchemaJsonFileLocater and SchemaXmlFileLocater
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): SchemaFileLocater | ||
addSchemaSearchPath(schemaPath: string): void | Add one search path used by this locator to find the | |
addSchemaSearchPaths(schemaPaths: string[]): void | Adds more search paths used by this locator to find the | |
getSchema(key: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | Schema> Abstract | Attempts to retrieve a Schema with the given SchemaKey by using the configured search paths | |
getSchemaKey(data: string): SchemaKey Protected Abstract |
Defined in
Last Updated: 23 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.