GoogleMapsMapLayerFormat Class
Extends
Methods
Name | Description | |
---|---|---|
constructor(): GoogleMapsMapLayerFormat | ||
createImageryProvider(settings: ImageMapLayerSettings): undefined | MapLayerImageryProvider Static | Create a MapLayerImageryProvider that will be used to feed data in a map-layer tile tree. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
register(): void Static Inherited | ImageryMapLayerFormat | Register the current format in the MapLayerFormatRegistry. |
validate(args: ValidateSourceArgs): Promise<MapLayerSourceValidation> Static Inherited | ImageryMapLayerFormat | Allow a source object to be validated before being attached as a map-layer. |
validateSource(_url: string, _userName?: string, _password?: string, _ignoreCache?: boolean, _accesKey?: MapLayerKey): Promise<MapLayerSourceValidation> Static Inherited | ImageryMapLayerFormat | Allow a source of a specific format to be validated before being attached as a map-layer. |
Properties
Name | Type | Description | |
---|---|---|---|
formatId Static | string |
Defined in
Last Updated: 23 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.