InvertedUnit Class

An InvertedUnit is a specific type of Unit that describes the inverse of a single Unit whose dimensional derivation is unit-less.

Extends

Methods

Name Description
fromJSON(invertedUnitProps: InvertedUnitProps): Promise<void>    
fromJSONSync(invertedUnitProps: InvertedUnitProps): void    
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): InvertedUnitProps Save this InvertedUnit's properties to an object for serializing to JSON.  
isInvertedUnit(item?: SchemaItem): item is InvertedUnit Static Type guard to check if the SchemaItem is of type InvertedUnit.  

Inherited methods

Name Inherited from Description
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited SchemaItem Indicates if the two SchemaItem objects are equal by comparing their respective key properties.
parseFullName(fullName: string): [string, string] Static Inherited SchemaItem Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings.

Properties

Name Type Description
invertsUnit Accessor ReadOnly undefined | LazyLoadedUnit    
schemaItemType Readonly SchemaItemType Get the type of item represented by this instance  
unitSystem Accessor ReadOnly undefined | LazyLoadedUnitSystem    

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly undefined | string SchemaItem  
fullName Accessor Inherited ReadOnly string SchemaItem  
key Accessor Inherited ReadOnly SchemaItemKey SchemaItem  
label Accessor Inherited ReadOnly undefined | string SchemaItem  
name Accessor Inherited ReadOnly string SchemaItem  
schema Readonly Inherited Schema SchemaItem  

Defined in

Last Updated: 23 April, 2025