EnumerationArrayProperty Class

Extends

Methods

Name Description
constructor(ecClass: ECClass, name: string, type: LazyLoadedEnumeration): EnumerationArrayProperty    

Inherited methods

Name Inherited from Description
fromJSON(enumerationPropertyProps: EnumerationPropertyProps): Promise<void> Inherited ArrayPropertyMixin(EnumerationProperty)  
fromJSON(propertyProps: PropertyProps): Promise<void> Inherited ArrayPropertyMixin(EnumerationProperty)  
fromJSONSync(enumerationPropertyProps: EnumerationPropertyProps): void Inherited ArrayPropertyMixin(EnumerationProperty)  
fromJSONSync(propertyProps: PropertyProps): void Inherited ArrayPropertyMixin(EnumerationProperty)  
getCategorySync(): undefined | PropertyCategory Inherited ArrayPropertyMixin(EnumerationProperty)  
getCustomAttributes(): Promise<> Inherited ArrayPropertyMixin(EnumerationProperty) Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited ArrayPropertyMixin(EnumerationProperty) Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited ArrayPropertyMixin(EnumerationProperty)  
isArray(): this is AnyArrayProperty Inherited ArrayPropertyMixin(EnumerationProperty)  
isEnumeration(): this is AnyEnumerationProperty Inherited ArrayPropertyMixin(EnumerationProperty)  
isNavigation(): this is NavigationProperty Inherited ArrayPropertyMixin(EnumerationProperty)  
isPrimitive(): this is AnyPrimitiveProperty Inherited ArrayPropertyMixin(EnumerationProperty)  
isStruct(): this is AnyStructProperty Inherited ArrayPropertyMixin(EnumerationProperty)  
toJSON(): EnumerationPropertyProps Inherited ArrayPropertyMixin(EnumerationProperty)  
toJSON(): PropertyProps Inherited ArrayPropertyMixin(EnumerationProperty) Save this Property's properties to an object for serializing to JSON.

Inherited properties

Name Type Inherited from Description
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory ArrayPropertyMixin(EnumerationProperty)  
class Accessor Inherited ReadOnly AnyClass ArrayPropertyMixin(EnumerationProperty)  
customAttributes Accessor Inherited ReadOnly undefined | ArrayPropertyMixin(EnumerationProperty)  
description Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(EnumerationProperty)  
enumeration Accessor Inherited ReadOnly undefined | LazyLoadedEnumeration ArrayPropertyMixin(EnumerationProperty)  
extendedTypeName Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(EnumerationProperty)  
fullName Accessor Inherited ReadOnly string ArrayPropertyMixin(EnumerationProperty) Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean ArrayPropertyMixin(EnumerationProperty)  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity ArrayPropertyMixin(EnumerationProperty)  
label Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(EnumerationProperty)  
maxLength Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(EnumerationProperty)  
maxOccurs Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(EnumerationProperty)  
maxValue Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(EnumerationProperty)  
minLength Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(EnumerationProperty)  
minOccurs Accessor Inherited ReadOnly number ArrayPropertyMixin(EnumerationProperty)  
minValue Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(EnumerationProperty)  
name Accessor Inherited ReadOnly string ArrayPropertyMixin(EnumerationProperty)  
priority Accessor Inherited ReadOnly number ArrayPropertyMixin(EnumerationProperty)  
propertyType Accessor Inherited ReadOnly PropertyType ArrayPropertyMixin(EnumerationProperty)  
schema Accessor Inherited ReadOnly Schema ArrayPropertyMixin(EnumerationProperty) Returns the schema of the class holding the property.

Defined in

Last Updated: 23 April, 2025