CurveExtendOptions Class
Logic for deciding how a curve may be extended for closest point or intersection searches.
Methods
Name | Description | |
---|---|---|
constructor(): CurveExtendOptions | ||
correctFraction(extendParam: VariantCurveExtendParameter, fraction: number): number Static | Correct fraction to be within [0,1]. | |
resolveRadiansToSweepFraction(extendParam: VariantCurveExtendParameter, radians: number, sweep: AngleSweep): number Static | Call resolveRadiansToValidSweepFraction and return only the fraction. | |
resolveRadiansToValidSweepFraction(extendParam: VariantCurveExtendParameter, radians: number, sweep: AngleSweep): { fraction: number, isValid: boolean } Static | Adjust a radians value to an angle sweep, extending beyond or clamping to [0,1] according to extendParam : |
|
resolveVariantCurveExtendParameterToCurveExtendMode(param: VariantCurveExtendParameter, endIndex: "0" | "1"): CurveExtendMode Static | Given a VariantCurveExtendParameter , isolate the particular CurveExtendMode in effect at an end. |
Defined in
- curve/CurveExtendMode.ts Line 29
Last Updated: 23 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.