PrimitiveOrEnumPropertyBase Class

Extends

Extended by

Methods

Name Description
fromJSON(propertyBaseProps: PrimitiveOrEnumPropertyBaseProps): Promise<void>    
fromJSONSync(propertyBaseProps: PrimitiveOrEnumPropertyBaseProps): void    
toJSON(): PrimitiveOrEnumPropertyBaseProps Save this PrimitiveOrEnumPropertyBase's properties to an object for serializing to JSON.  

Inherited methods

Name Inherited from Description
getCategorySync(): undefined | PropertyCategory Inherited Property  
getCustomAttributes(): Promise<> Inherited Property Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited Property Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited Property  
isArray(): this is AnyArrayProperty Inherited Property  
isEnumeration(): this is AnyEnumerationProperty Inherited Property  
isNavigation(): this is NavigationProperty Inherited Property  
isPrimitive(): this is AnyPrimitiveProperty Inherited Property  
isStruct(): this is AnyStructProperty Inherited Property  

Properties

Name Type Description
extendedTypeName Accessor ReadOnly undefined | string    
maxLength Accessor ReadOnly undefined | number    
maxValue Accessor ReadOnly undefined | number    
minLength Accessor ReadOnly undefined | number    
minValue Accessor ReadOnly undefined | number    

Inherited properties

Name Type Inherited from Description
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory Property  
class Accessor Inherited ReadOnly AnyClass Property  
customAttributes Accessor Inherited ReadOnly undefined | Property  
description Accessor Inherited ReadOnly undefined | string Property  
fullName Accessor Inherited ReadOnly string Property Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean Property  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity Property  
label Accessor Inherited ReadOnly undefined | string Property  
name Accessor Inherited ReadOnly string Property  
priority Accessor Inherited ReadOnly number Property  
propertyType Accessor Inherited ReadOnly PropertyType Property  
schema Accessor Inherited ReadOnly Schema Property Returns the schema of the class holding the property.

Defined in

Last Updated: 23 April, 2025