CatalogConnection.openReadonly Function
Open a CatalogIModel for read access.
openReadonly(args: CatalogIModel.OpenArgs): Promise<CatalogConnection>
@returns the CatalogConnection to access the contents of the Catalog.
@note CatalogConnection extends BriefcaseConnection. When finished reading, call close
on the connection.
Parameter | Type | Description |
---|---|---|
args | CatalogIModel.OpenArgs |
Returns - Promise<CatalogConnection>
the CatalogConnection to access the contents of the Catalog.
Defined in
Last Updated: 23 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.