TextureMapping.Params Class
Parameters describing how a RenderTexture's image is mapped to a surface.
Methods
Name | Description | |
---|---|---|
constructor(props?: TextureMapping.ParamProps): TextureMapping.Params | ||
compare(other: TextureMapping.Params): number | An OrderedComparator that compares these Params against other . |
|
computeUVParams(visitor: IndexedPolyfaceVisitor, localToWorld: Transform...): undefined | Point2d[] | Compute texture coordinates for a polyface. |
Properties
Name | Type | Description | |
---|---|---|---|
constantLodParams | TextureMapping.ConstantLodParams | Parameters for constantLod mapping mode. | |
mode | TextureMapping.Mode | The mode by which to map the image to a surface. | |
textureMatrix | TextureMapping.Trans2x3 | The matrix used to map the image to a surface. | |
useConstantLod | boolean | True if want to use constant LOD texture mapping for the surface texture. | |
weight | number | The ratio in [0, 1] with which to mix the color sampled from the texture with the element's color. | |
worldMapping | boolean |
Defined in
- core/common/src/TextureMapping.ts Line 195
Last Updated: 23 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.