queryViews Method
Query for a list of ViewInfos for views that match the supplied QueryParams.
queryViews(queryParams: ViewStoreRpc.QueryParams): Promise<ViewStoreRpc.ViewInfo[]>
@note The array will be sorted by name, ascending. To limit the size of the array, supply limit
and offset
in the QueryParams.
Parameter | Type | Description |
---|---|---|
queryParams | ViewStoreRpc.QueryParams |
Returns - Promise<ViewStoreRpc.ViewInfo[]>
Defined in
- core/backend/src/ViewStore.ts Line 1290
Last Updated: 29 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.